NetBSDをinstallしたCompactFlashをUSL-5Pに 差し込み、起動してみましょう。以下の様に"login:"という表示が でたら、"root"でloginします。
... Sat Feb 29 01:02:03 UTC 2020 swapctl: adding /dev/wd0b as swap device at priority 0 Checking for botched superblock upgrades: done. Starting file system checks: /dev/rwd0a: file system is clean; not checking Setting tty flags. Setting sysctl variables: Starting network. Hostname: usl5p.example.com Configuring network interfaces: re0. add net default: gateway 192.168.1.254 Adding interface aliases: Building databases... Starting syslogd. Checking for core dump... savecore: no core dump Setting RTC offset to 0. Mounting all filesystems... Clearing /tmp. Setting securelevel: kern.securelevel: 0 -> 1 Starting virecover. Starting local daemons:. Starting powerd. Starting sshd. postfix: rebuilding /etc/mail/aliases (out of date /etc/mail/aliases.db) postfix/postfix-script: starting the Postfix mail system Starting cron. Sat Feb 29 01:02:03 UTC 2020 NetBSD/landisk (usl5p.example.com) (console) login: root NetBSD 5.0 Welcome to NetBSD! #
rootでちゃんとloginできればinstall成功です。なお、電源断は以下の commandか、電源ボタン長押しです。
# shutdown -p now #
再起動するなら"-r"を指定します。
# shutdown -r now #
Serial consoleの代わりにtelnetを使う場合、root loginはできません。 NetBSDをinstallしたときに、someoneという userを作ったはずなので、そのuserでloginした後、"su -"でrootに なってください。
$ telnet 192.168.1.100 Trying 192.168.1.100... Connected to 192.168.1.100. Escape character is '^]'. NetBSD/landisk (usl5p.example.com) (ttyp0) login: someone Password: hogehoge Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008 The NetBSD Foundation, Inc. All rights reserved. Copyright (c) 1982, 1986, 1989, 1991, 1993 The Regents of the University of California. All rights reserved. NetBSD 5.0 Welcome to NetBSD! usl5p$ su - usl5p#
起動するようになったら、とりあえず時刻とtimezoneの設定をしましょう。ま ず、timezoneを次のようにして"Tokyo"にします。
# ln -sf /usr/share/zoneinfo/Asia/Tokyo /etc/localtime #
次に時刻を設定します。手動で設定するなら"date"を使います。次 のようにすると、内蔵の時計が2001年2月3日4時5分に変更されます。
# date 200102030405 #
もしくは、"ntpdate"を使ってNTP serverに時刻を合わせることもで きます。Networkに繋がっているなら、こちらの方が簡単で正確に時計を合わせ ることができます。
# ntpdate ntp.example.com #
この節はお好みに応じて設定してください。
私は長らくLinuxを使っていたため、NetBSD標準のcshにどうも馴染めません。 ということで、まず最初にshellを/bin/shに変更します。
# chsh -s /bin/sh #
続いて、/root/.profileを編集して環境変数やaliasの設定などを行います。
set -o tabcomplete set -o emacs export PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/pkg/sbin:/usr/pkg/bin export PATH=${PATH}:/usr/X11R6/bin:/usr/local/sbin:/usr/local/bin export HOST="$(hostname)" if [ -z "$TERM" ] || [ "unknown"=="$TERM" ]; then export TERM=vt100 fi umask 022 alias rm='rm -i' alias cp='cp -i' alias mv='mv -i' alias la='ls -aF' export ENV=/root/.shrc
IPを固定で割り振る場合について説明します。以下の情報が必要ですので確認 してください。
実際の設定ですが、 hostname、default gateway、IPとnetmaskを /etc/rc.confに書きます。
hostname=usl5p.example.com defaultroute=192.168.1.254 ifconfig_re0="inet 192.168.150.251 netmask 255.255.255.0"
DNSを/etc/resolv.confに書いて完了です。
domain example.com nameserver 192.168.1.250 nameserver 192.168.1.251
以下のcommandでnetworkの設定を反映させます。
# /etc/rc.d/network restart #
Serverとして使う場合はDHCPでIPを割り当てることは稀だとは思いますが、 DHCPの場合の設定も書いておきます。
設定するは簡単で、"hostname"と"dhclient"を /etc/rc.confに書き加えるだけです。
hostname=usl5p.example.com dhclient=YES dhclient_flags="re0"
build.shの時に、"USE_INET6 = no"
していると、起動時に"IPv6 support is disabled"という警告が大
量に出ます。ウザいので、/etc/postfix/main.cfを書き換えましょう。
"inet_protocols = all"となっているところを、
"inet_protocols = ipv4"と変更するだけです。